User Tag List

Ergebnis 1 bis 7 von 7

Thema: Models mit Normalmapping werfen keine Schatten auf sich selbst

  1. #1
    Administrator Avatar von DaEngineer
    Registriert seit
    23.06.2010
    Beiträge
    1.576
    Blog-Einträge
    2
    Renommee-Modifikator
    20

    Models mit Normalmapping werfen keine Schatten auf sich selbst

    Nabend.

    Ich versuche gerade, für Cliffside die namensgebende Klippe als Model umzusetzen. In der Klippe sind unten Tunnel, durch die man laufen kann. Diese Tunnel sind eigentlich dunkel, weil von außen kein Licht hereinkommt. Sobald die vmt des Models allerdings $bumpmap enthält, wirft das Klippenmodel keine Schatten mehr auf sich selbst, wodurch die Tunnel hell werden:

    Klicke auf die Grafik für eine größere Ansicht 

Name:	fels innen.jpg 
Hits:	112 
Größe:	106,2 KB 
ID:	5013

    Ohne Normalmap sieht der Fels aber nicht gerade allzu toll aus. Das Mesh ist zwar noch nicht fertig und es gibt auch noch keine Smoothinggroups, aber dass es mit Normalmap besser aussehen würde, sieht man jetzt schon:

    Klicke auf die Grafik für eine größere Ansicht 

Name:	fels aussen.jpg 
Hits:	108 
Größe:	233,5 KB 
ID:	5011

    Im Valve Developer Wiki steht im Artikel zu $bumpmap: "Warning: $bumpmap will disable prop_static's per-vertex lighting. Not enough data is stored in the vertices for normal mapping, so the engine has no choice but to fall back."

    Kann man da was machen? Ich würde eher die Normalmap weglassen als auf die Schatten zu verzichten, aber am besten wäre natürlich beides zusammen.

  2. #2
    Moderator Avatar von Campeòn
    Registriert seit
    20.06.2010
    Ort
    Bielefeld
    Beiträge
    2.205
    Blog-Einträge
    1
    Renommee-Modifikator
    23
    In CS:S war das was du willst nicht möglich und ich bezweifle, dass es unter CS:GO neue Möglichkeiten gibt. :/ Sorry.
    Because we do not know when we will die, we get to think of life as an inexhaustible well, and yet everything happens only a certain number of times ... And a very small number really. How many more times will you remember a certain afternoon of your childhood ... an afternoon that is so deeply a part of your being that you can't even conceive of your life without it? Perhaps four or five times more. Perhaps not even that. How many more times will you watch the full moon rise? Perhaps 20. And yet it all seems limitless.

  3. #3
    Mitglied Avatar von Av3ris
    Registriert seit
    21.09.2010
    Beiträge
    489
    Renommee-Modifikator
    14
    Hab leider auch nichts gefunden, um das zu umgehen. Und die einzige Möglichkeit, die hässlichen Schatten in der Version ohne Bumpmap schön rund zu kriegen, ist dann auch, die Polyzahl nach oben zu schrauben. Soweit meine Erfahrungen.
    Bei sowas könnte man sich echt die Haare ausrupfen

    Edit: Was für dich vllt. eine Option wäre: Das Lighting im Modelprogramm bereits auf die Textur backen. Dann kannst du das Teil mit der Normal-Map wiedergeben und hast gleichzeitig das reudige Beleuchtungsproblem umgangen. Kann sich aber eben je nach Einsatz zusätzlich auf die Dateigröße niederschlagen, weil man dann eventuell mehrere Models braucht.
    Geändert von Av3ris (28.04.2013 um 11:51:46 Uhr)

  4. #4
    Moderator Avatar von Dmx6
    Registriert seit
    18.06.2010
    Ort
    Zwischen Frankfurt und Darmstadt
    Alter
    29
    Beiträge
    958
    Blog-Einträge
    3
    Renommee-Modifikator
    20
    Die Beschreibung des $bumpmap Befehls besagt ja das per-vertex lighting deaktiviert wird.

    Der Compileparameter -StaticPropLighting aktiviert jedoch dieses:

    -staticproplighting calculates per-vertex lighting for static props. Before all static props were lit by a single calculation at their origin or lighting origin. If that was inside a wall the prop was black, if it was in shade the entire prop was dark, if it was in light the entire prop was bright. Now though if half a model is in light and half is in shade, only the vertices that are in light are bright and if part of the prop is inside a wall then only the vertices that are actually inside the wall are black.
    Eventuell kannst du das so von der Engine erzwingen.

  5. #5
    Administrator Avatar von DaEngineer
    Registriert seit
    23.06.2010
    Beiträge
    1.576
    Blog-Einträge
    2
    Renommee-Modifikator
    20
    Zitat Zitat von Dmx6 Beitrag anzeigen
    Eventuell kannst du das so von der Engine erzwingen.
    Leider nein. Ich werd mich wohl damit abfinden und auf die Normalmaps verzichten müssen :/

  6. #6
    unterteile das Model. Baue mit Nodraw es grob nach. Das sollte dir die Schatten bringen die du willst.
    Michael_Z <- -> Term!nator525

  7. #7
    Erfahrenes Mitglied Avatar von xnyYy
    Registriert seit
    29.11.2010
    Ort
    Essen
    Alter
    24
    Beiträge
    547
    Renommee-Modifikator
    11
    Entweder wie bereits gesagt mit nodraw grob nach bauen, oder mit einer (ich meine) blocklight textur nachbauen.
    Kommt denke ich aufs gleiche hinaus

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
[email protected]