User Tag List

Ergebnis 1 bis 7 von 7

Thema: Suche Mapcompiler wegen Schattenbug

  1. #1
    Neues Mitglied
    Registriert seit
    17.09.2012
    Beiträge
    18
    Renommee-Modifikator
    0

    Suche Mapcompiler wegen Schattenbug

    Ich habe einen Lichterbug und dieser geht nur weg wenn man auf NORMAL statt auf FAST kompiliert. Allerdings dauert normal sowohl bei mir als auch bei einem Kumpel viel zu lange. Kann das vielleicht einer von euch sehr schnell machen weil ihr einen super PC habt oder so? Oder gibt es vielleicht andere Möglichkeiten diesen schwarzen Schattenbug wegzubekommen? Bitte helft mir.

  2. #2
    Administrator Avatar von DaEngineer
    Registriert seit
    23.06.2010
    Beiträge
    1.576
    Blog-Einträge
    2
    Renommee-Modifikator
    20
    Seit dem letzten großen Engineupdate für CS:GO musst du über das Custom Menü compilen und weitere Parameter anhängen. @BaShoR hat da einen Thread zu erstellt, in dem auf einen Artikel von Valve zum Thema verlinkt wird. Habt ihr uralte CPUs oder hast du in deiner Map irgendwelchen unchristlichen Dinge getan, dass du so lange compilst? Und wie lange ist "lang"?

  3. #3
    Neues Mitglied
    Registriert seit
    17.09.2012
    Beiträge
    18
    Renommee-Modifikator
    0
    Ich habe mir das jetzt durchgelesen von Valve aber werde drauß nicht schlau wie ich das am besten machen kann, dass ich auf fast compilen kann ohne, dass der Schatten kommt und ich will ungerne bei den Einstellungen herumbasteln sonst geht vielleicht garnichts mehr . Bitte helft mir.

  4. #4
    Administrator Avatar von DaEngineer
    Registriert seit
    23.06.2010
    Beiträge
    1.576
    Blog-Einträge
    2
    Renommee-Modifikator
    20
    Du solltest nicht auf fast compilen, weil das seit diesem Update genau diese Fehler verursacht. Drück F9, wähle unten links Expert aus und wähle dann das Preset "Full compile - HDR only" aus. Klicke auf der linken Seite den Eintrag $light an, auf der rechten Seite siehst du die Parameter dazu. Kopiere in das Feld Folgendes rein und ersetze komplett den Text, der schon darin steht:

    -textureshadows -hdr -StaticPropLighting -staticproppolys -game $gamedir $path\$file

    Wenn du zusätzlich (z.B. ganz am Anfang, noch vor -textureshadows) den Parameter -low angibst, fängt dein PC beim Compilen nicht an zu stottern, aber der Vorgang kann leicht länger dauern. Falls in der Liste auf der linken Seite die unterste Box $game_exe aktiviert sein sollte, bitte deaktivieren. Die vier Boxen darüber aktivieren. $vis_exe kannst du ausmachen, wenn du deine Map noch nicht für VIS optimiert hast (func_details, Portale). Über den Go! Button unten rechts startest du das Compile. Mit diesem Dialog solltest du immer compilen, das normale Menü funktioniert seit dem Update nicht mehr vernünftig, weil der Befehl -StaticPropLighting jetzt benötigt wird. -staticproppolys berechnet Schatten für Meshes anhand von deren Geometrie und nicht nach ihrem Collisionmesh.

    Wenn deine Map ein Leak hat, solltest du das so oder so schließen, bevor du Licht compilst.
    Geändert von DaEngineer (27.09.2016 um 03:07:26 Uhr)

  5. #5
    Neues Mitglied
    Registriert seit
    17.09.2012
    Beiträge
    18
    Renommee-Modifikator
    0
    So ich habs so probiert wie du geschrieben hast aber da sitze ich 100 Jahre. Was ist wenn ich die neuen Lightoptionen bei Fast anwende? Müsste doch dann auch klappen oder?

  6. #6
    Administrator Avatar von DaEngineer
    Registriert seit
    23.06.2010
    Beiträge
    1.576
    Blog-Einträge
    2
    Renommee-Modifikator
    20
    Du kannst in die light Variablen noch -fast mit dazuschreiben und gucken, ob das funktioniert. Aber nach wie vor, -fast produziert Fehler und schlechte Qualität. Wenn du damit Probleme hast, wird dir hier keiner helfen, weil du die Probleme selber absichtlich verursachst. Das ist wie mit Leaks. So lange du Leaks in deiner Map hast, sind alle anderen Turnübungen unnötig, weil du erstmal das offensichtliche Problem lösen musst.

    Du hast uns auch noch nicht verraten, wie lange das Compile bei dir dauert.
    Geändert von DaEngineer (28.09.2016 um 13:28:43 Uhr)

  7. #7
    Mapping-Profi Avatar von eMo
    Registriert seit
    10.12.2010
    Beiträge
    2.024
    Renommee-Modifikator
    21
    Nein, es klappt nicht.
    Compilen dauert nun einmal so lange wie es dauert, da kann man nix machen. de_cache hat z.B. über 24h compiled afaik. Je komplexer deine Map ist und je schlechter sie optimiert ist, desto länger dauert das nunmal. Fast geht schnell, weil es eben nicht so genau ist und daher entstehen auch die Schattenbugs.
    Ein kreativer Geist findet immer eine Möglichkeit, sich auszuleben.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
[email protected]